Eclipse Mylyn 3.21

Primary tabs

Release Date: 
Friday, October 7, 2016
Deliverables: 

The Mylyn project coordinates a release of all participating sub-projects.

Mylyn Builds 1.13

  • Builds Framework
  • Hudson/Jenkins Connector
  • Builds SDK

Mylyn Commons 3.21

  • Discovery Framework
  • Identity Framework
  • Interaction Monitoring Framework
  • Notification Framework
  • Repository Framework
  • Transport Framework
  • HTTP Transport
  • XML-RPC Transport
  • UI Toolkit
  • Commons SDK

Mylyn Context 3.21

  • Focused UI
  • Eclipse IDE Bridge
  • Java Development Bridge
  • Plug-in Development Bridge
  • Team Support Bridge
  • C/C++ Development Bridge
  • Context SDK

Mylyn Docs 2.10

  • WikiText
  • HtmlText
  • EPUB
  • Docs SDK
  • WikiText SDK
  • EPUB SDK

Mylyn Reviews 2.12

  • Reviews Framework
  • Gerrit Connector
  • Reviews SDK

Mylyn Tasks 3.21

  • Task List
  • Bugzilla Connector
  • Trac Connector
  • Tasks SDK
  • Tasks Tests SDK

Mylyn Versions 1.13

  • Versions Framework
  • CVS Connector
  • Git Connector
  • Subclipse Connector
  • Versions SDK

 

Compatibility: 

API Contract Compatibility: Mylyn 3.21 will be backward compatible with Mylyn 3.0.

Binary (plug-in) Compatibility: Mylyn 3.21 will be binary compatible with Mylyn 3.0.

Source Compatibility: Mylyn 3.21 will not be source compatible with previous versions.

Workspace Compatibility: Workspaces created with Mylyn 2.x, last released in February 2008, cannot be opened with Mylyn 3.21. We intend to keep Mylyn 3.21 upwards workspace-compatible with all versions higher than Mylyn 3.0, released in June 2008, unless noted. This means that workspaces created with Mylyn 3.0 can be successfully opened by Mylyn 3.21 and upgraded to a 3.21 workspace. Workspaces created by earlier versions cannot be opened by Mylyn 3.21. However, if users upgrade to Mylyn 3.19, they will be migrated to the format used since Mylyn 3.0, and users can then upgrade to Mylyn 3.21.